博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
Problem D
阅读量:5960 次
发布时间:2019-06-19

本文共 949 字,大约阅读时间需要 3 分钟。

Problem Description

Eddy's interest is very extensive, recently he is interested in prime number. Eddy discover the all number owned can be divided into the multiply of prime number, but he can't write program, so Eddy has to ask intelligent you to help him, he asks you to write a program which can do the number to divided into the multiply of prime number factor .

Input

The input will contain a number 1 < x<= 65535 per line representing the number of elements of the set.

Output

You have to print a line in the output for each entry with the answer to the previous question.

Sample Input

119412

Sample Output

112*2*13*181

#include <iostream>

using namespace std;
int main()
{int p(int n);
    int n;
while(cin>>n)
{int i,k=0;
    n=p(n);
    for(i=2;i<n;i++)
    if(n%i==0)
    {
    n=p(n);
    i=1;}
    cout<<n<<endl;
    }
return 0;}
int p(int n)
{int i;
for(i=2;i<n;i++)
if(n%i==0)
{n=n/i;
cout<<i<<"*";
break;
}
return n;
}

转载于:https://www.cnblogs.com/lengxia/p/4387889.html

你可能感兴趣的文章
深入浅出: 大小端模式
查看>>
深入浅出: Java回调机制(异步)
查看>>
Aliyun OSS Nginx proxy module(阿里云OSS Nginx 签名代理模块)
查看>>
linux中的mdev机制
查看>>
use zfs snapshot rollback postgresql's primary to old status in PG HA
查看>>
btrfs 使用指南 - 1 概念,创建,块设备管理,性能优化
查看>>
Android Studio 3.0 上 Gradle 改动
查看>>
[Vue]1-5. Vue.js核心知识之组件化
查看>>
链表(二)
查看>>
重学前端之 让人心态爆炸的this到底是个什么玩意
查看>>
阿里云服务器ECS 3年 279元
查看>>
lamp组合详解
查看>>
Android 自定义View基础(一)
查看>>
新锐时代(北京)网络科技有限公司拖欠工资
查看>>
(四)构建springmvc+mybatis+dubbo分布式平台-maven代码结构
查看>>
去掉键盘的方式
查看>>
css代码规范
查看>>
深入理解Spring系列之三:BeanFactory解析
查看>>
推荐几款超好用的Android Stuido插件
查看>>
C#实现.Net对邮件进行DKIM签名和验证,支持附件,发送邮件签名后直接投递到对方服务器(无需己方邮件服务器)...
查看>>